pdf creation is SLOW

My users are complaining about the extensive time it takes to generate a 26 page pdf; I’ve time it at just over five minutes and that is with still very little activity and very few users on the system. Some of our reports are over a 100 pages so this is very distressing t our users. Our old system (Oracle Reports) was much faster and they are saying as much.

Another thing we have noticed is that the pdf being generated is HUGE. For example the old version of the 26 page report for Sept is only 85kb whereas the Dundas version that has the same data is almost 80 times larger at 6633kb:

Is anything being done to improve the pdf creation?

1 Like

sounds like something you should investigate in details with the support team as there is probably a need to dive deeper into your setup but I do have a quick question - do you happen to have images in your report? specifically JPG images?
As a side note you can always schedule the reports export to PDF and generate those to email or a shared folder in advance.

No images. Text only. I have told my users about scheduling notifications, but the 80x larger file and the time delay is a real problem for my users.

Ok - I’ll ask the support team to reach out to you for more details so they can do a deeper investigation.

Even we are facing the same issue. Following up with support team but no progress yet.

Been through this and other report issues numerous times with support. I was told that this is a CEFSharp issue that has been resolved in Chromium 62, but that it may take some time to implement the fix.

Good news on this one - the team found a way to optimize the generated PDF file size. This should have a significant impact on the file size making it much smaller (similar to the size you currently get from your other system). This change will be part of our next revision (so will apply to both Dundas BI 5 and 6). An update will be provided as soon the next revision is released in the upcoming weeks.

This is BRILLIANT. Also very glad to hear it is included in the V5 revision!

Hi Ariel, we upgraded to version 6 and still have same issues. There is an open ticket on this issue with support #75192. I always hear back that 200-300 page report is a huge file according to Dundas support and have no answer when can this process be improved.

Any other tool except Dundas is creating same reports in less than a minute or in just few seconds. Could you please provide us with any realtime solution?

Hi Sunil,

We understand your concern and our R&D team is working vigorously on finding a solution. It’ll take some time.

In the meantime, we’d like to work with you together to find an alternative solution. Based on the information you sent to Support, will it work for you to get the expected report by running the report on each individual employee and then use an automated PDF merging tool to merge all the PDFs into one?

Another suggestion would be to set up a notification for each employee and set up the parameters to filter the report on that employee. As I am aware that your report is being used to distribute a report for each employee that requires them to sign off on, this alternative could solve your issue and save you time by automating the distribution process.

We can definitely discuss offline with your specific use case and provide more details.


Is this not fixed with a revision then? This is one of our top complaints and I’m in the process of converting another report to Dundas that will result in a pdf with many pages. Do we have a timeline on when this might be fixed?

@joyce.young I don’t think the issue above is the same as your issue. I would recommend trying your PDF export in our latest version 5 revision or in the new version 6 - both include optimizations to greatly reduce the generated file size.

Please let us know if you still an issue when trying with those new versions.

This thread was started by me. I’m still experiencing this issue.

I upgraded my beta box today to the latest v5 revision ( ) in order to test the “pdf creation is slow” issue I reported. On the latest v5 revision the first time I ran the report the pdf creation seemed to run for about five minutes and then I got a message about “the transaction log for database is full”. The second time I ran the report it still ran for over 4.5 minutes, but it actually generated the pdf. The pdf size is still huge, at 6,569 kb versus 85kb in our current reporting solution for the same data.

This seems to be two issues:

  1. The pdf creation is still taking too long. The latest revision does not seem to have fixed anything with regard to size or generation speed.
  2. My transaction log is full? This is a standalone instance that is only used to test version upgrade so I’m not sure why this would have anything other than the copy what I pulled from our test instance. I’ll be sending this part along to support to see if they can help me understand that part.

Hi Joyce,

PDF exports having inflated file sizes is part of a known defect (Issue 75192) that has been resolved in V6. However, you can resolve this in V5 by adding the following CSS styling in your CSS override file.

* {
     text-shadow: none !important;

The CSS override file is located in your instance’s “/Content/Override” directory and the file name you will be looking for is “style.override.css”. You can open/edit it using most standard text/code editors. More information on CSS overrides is available here.

Please let me know if this works for you or if you have any additional questions.

Thank you for the location. I’ve tried logging into my server (I’m an admin) and I can find the file, open it and copy it, but it won’t let me save any edits the file.

Please advise.

Save the file to the desktop and then copy + paste the file back to the directory. Windows will ask for confirmation and it should save. Recycle app pool and try to export. Might need to stop the scheduler to recycle the app pool

Kevin, I have tried that. I have tried all of the following:

  1. open original file, edit and save. It fails.
  2. copy original file to my desktop. edit that file, save it over original file. It fails.
  3. copy original file to my desktop. edit that file, delete original file. copy/paste desktop file. It fails.
  4. copy original file to same location. edit copy file. save copy over original file, it fails.

Do I need to stop the webserver?

Hi Joyce, are you still experiencing the issue? when it fails, is there any error message? Have you checked if you have permission to edit that file by looking at the properties?

Yes. I even tried stopping the webserver before editing the file:

Hello Joyce,
I beleive this is just NTFS permission on the folder that prevents the copy. I face these issues usually.

Right click on override folder and choose properties - in security tab you can give the needed permission on the folder to allow the modify. I suggest here to add everyone group and give full permission . And revert back to original security configuration once you finish the copy.

And just to note here, using the admin user on the server is not enough for the copy. You need to play with the permission.