Strange behavior when copying list with data input interaction

So, I had a data cube with a field called “facility” that had 4 different facilities, and I needed to create 4 dashboards with mostly the same input fields for the different facilities (with a few changes and different filtered visualizations for each dashboard) to be able to switch layers between them. 3 of the facilities had been entered into the data cube already, and 1 had not.

I used a dropdown list to input the facility name and removed the facilities that did not apply for each dashboard so that there was only one entry. I copied the dashboard and changed it for the first 3 facilities, and everything worked. I did the same for the one that was not yet in the data cube, and the facility would not show up in the data, so I could not filter the metric sets on the dashboard to it. I tried the following to get it to work:

  • Recreating the list instead of using the copied version
  • Deleting the data input interaction on the button and resetting all the inputs
  • Refreshing the data in the metric sets
  • Re-adding the metric sets to the dashboard

Finally, I tried going back to view and reselecting the facility displayed by opening the dropdown and selecting the only option. When I did this, not only did the facility finally appear in the data to add to metric sets, all the data I had entered previously was there once I filtered!

This seems very odd. If the data was there, why couldn’t I filter to it? Why reselect the option that’s selected? This seems like it could be a smoother and more intuitive process.

1 Like

Hi Lindsey,

Thank you for bringing this to our notice. Usually, when you copy a dashboard you can just refresh the dashboard so it’s updated with the latest data etc. Have you tried that before you deleted the metric sets and added them back?

I can’t say for certain which one I did first at this point, but I did refresh the data, yes. The weird thing is it’s set up on the input interaction to refresh the data already, and I’d never had this issue until this dashboard.