Stop Grouping in second hierarchy

Hey gang,

Hope all of you are doing well!

I have a frustrating issue with unwanted automatic grouping that I hope someone could shed some light on.

Essentially I have a table with 3 hierarchies, and 3 measure.
I want to sort the data by 1 hierarchy (the Product) and then 1 measure (Sales - descending).

Unfortunately a second hierarchy has names that repeat, therefore when I create the sort, it groups the 2 together :frowning:

As you can see each of the rows has a figure, but it seems to be sorting by the sum of the person in total and then ordering so I get a random 3 which actually should be showing at the bottom.

I have tried unspecifying sort orders and all sorts, used in a grouped and flat table, but still no joy…help please :stuck_out_tongue:


Hi Chris,

The popup you’re probably using to sort the columns (via the A-Z icon in your screenshot) should look like this, and in version 10 there is also a new option there labelled “(None)”:

(Image taken from this article)

Yes by default placing your data under Rows in the Data Analysis Panel in this order means it should be grouped into rows first by Product HO, then by Surveyor Name, then by Unit (1), but the “(None)” option allows you to bypass this and disable all grouping. Before version 10, you could also effectively bypass grouping if you have any hierarchy that is unique to every row such as an ID, by placing this first under Rows in the Data Analysis Panel or choosing this hierarchy from the “Grouped first by” drop down.

Thanks Jamie,
Unfortunately I have not upgraded to 10 yet, which explains why I can’t do what I am trying to achieve. However this has now pushed me to complete the UAT testing and hopefully upgrade over the weekend.
Bring on v.10 :slight_smile:

1 Like