Settings for filling nulls?

I am pulling my hair out…

I have 2 instances - dev and prod.

On my dev instance, I’ve set up data cubes to fill nulls the way I want them to. They look great.

On my prod instance, where I never direct-edit anything (i.e., I only import from dev) it is filling all nulls with (empty string).

I have gone through every data cube, every setting I can find, but nowhere do I see anywhere that would cause this to happen.

Where are there settings to override null fill?

Hi Ken,

It looks like you don’t have the same localization override as you have in the development environment. You can check the article about override localization and handling “Empty String” from here on our support site. Moreover, this article is very helpful for “Handling missing data”, and we can override values to fill null.


Thank you! Apparently I had found that article a while back and implemented it on the dev server, because I did indeed find that mod in my localization. Now I’ll look into why it didn’t come over with my exports.

One addition: we’re on Ubuntu/Postgres, not Windows/MySQL, so recycling the application pool wasn’t an option. However, I was able to just do a “reload extensions” within DBI to get it to apply the changes immediately.

1 Like

UPDATE: this process is different in version 9. Following the instructions in the “here” link in Bhavankit’s post: When you create the copy and go to edit it, the GS_ENT_HC_EmptyString entry, it is ALREADY there. You should search for it and edit it, rather than creating a new entry in the file (it will throw an error).

UPDATED UPDATE: Nope, that’s not true. That’s what happens if you accidentally create a different culture so it doesn’t override. Process is the same if you do it right!

1 Like