Keeping Dashboard at Lowest Member of a Hierarchy


is there a way to keep a dashboard hierarchy rolled out to show every member? Every time I check it in it reverts back to everything rolled up. These reports need to be scheduled to show every member of the hierarchy so I can’t keep rolling it up and down.


Hi Patrick,

It depends on the visual you’re using on your dashboard. If you’re referring to a table (let me know if you’re using a different visual), you could set the hierarchy to the lowest level as shown in the example below(first picture) and your result would be as shown in the table(second picture).



Once you have that set you could check in your dashboard and verify. Let me know if that works for you.

Hi Satya,

I gave this a try. A couple of concerns. I have my table set up in “Row Header Layout” of Indented to replicate pivot tables. When I do this and set it to the bottom most level (in this case level 3) my report only shows me level 3 data. If I set it to Top Level of Level 1 and Level as “All Members” for my ragged hierarchy I get most of the data showing, however it looks like my level two headers are now hidden. I don’t remember this functionality happening before the upgrade. Please see examples below

Here is the ragged hierarchy showing Level 1

When I drill to level two level 1 totally disappears

When I drill into level 3 (MPPA) Level 2 totally disappears

For this to work as expected I would want all levels to show and not go back to a just showing 1 level at a time.

Hi Patrick

It’s not completely clear from the images, but it sounds like Level on this hierarchy in the metric set was at some point set to a specific level rather than “All Members”. When you choose “All Members”, Top Level is not used and instead all members from all levels are displayed, so you can leave that setting alone.

When only one level at a time is displayed, I think you’re clicking the triangle to expand values and those values disappear when the table is using indented row headers. Indented row headers require totals to be enabled, because tables don’t support inserting an otherwise empty row to maintain a place for the expanded hierarchy member without them. This is not new, but you may not have been using indented row headers before or there may have been total rows present.

I hope this helps.

Hi Satya,

I was able to figure it out and you are correct. The parameter value must be set to level = “all members”. I also set top level to the top most level of my hierarchy. As for the indented row and totals, I was able to set a grand total off a field that I hid. The field was simply the report set I was looking at. The hierarchy was set to subtotal and I hid the grand total.

1 Like