Error while running the dashboard when we select the children of a user defined hierarchy

Hi Team

I am getting below error while running my dashboard . Prima facie it looks like some column is missing in the group by clause but there is more to it because when I run the dashboard for small data set it runs successfully however for larger data set it throws the below error. Also I can load the metric set behind this dashboard for small data set.

An unexpected error occurred when retrieving data using data connector ‘[Partner Ecosystem - OCMS] Data Connectors Root Folder/IZBLUDBDEV’. ERROR [42803] [IBM][DB2/LINUXX8664] An expression starting with “TE19” specified in a SELECT clause, HAVING clause, or ORDER BY clause is not specified in the GROUP BY clause or it is in a SELECT clause, HAVING clause, or ORDER BY clause with a column function and no GROUP BY clause is specified.

Note : There is one table and metric set used in this dashboard and we directly export the result of the dashboard in an excel sheet.
Also we recently upgraded to Version: if that has any impact.
Any pointer to narrow down the issue would be helpful.

UPDATE : We have narrowed down the issue and it is related to Brand hierarchy where the Dundas is not picking any of the children in the brand hierarchy. And when ever we select the children it throws the above error . Is it due to recent patch upgrade or anything else ? Any insights to resolve it would be helpful.

Hi Aditya,

Assuming Brand is a user defined hierarchy, can you open the hierarchy from main explore menu and expand its levels to see the sub-levels? Is the hierarchy built from a cube or the data connector directly?
Either way, can you do the same interaction to reproduce the error again and track the query generated by Dundas (by going to admin > setup > config > log filter > turn Query Audit under Data Retrieval to “verbose”) and then run the same query logged in Application Logs directly in DB2 to verify if it runs successfully?

Can you please email with your findings, in case the issue is not resolved? I have created a ticket (92917) under your name since the same issue has been reported by other users from IBM who do not have developer/power user access.

Hi Upasana Thanks for the response . Yes it is a user defined hierarchy created from a data connector and we are able to expand the children of the hierarchy but when the child is selected and dashboard is run we get the above error. Also this error is not related to one hierarchy . We have 2 -3 user defined hierarchies and we get the same error when we select the child node and run the dashboard.

Updated the title so that it makes more sense
I have sent an email to the above eamil id as suggsted by you. Let me know if you need any additional info.