Error upon import

Hi everyone,

I am facing an annoying issue while importing some objects from a Dundas BI instance (running on Windows) into another one (running on Linux via Docker).

I get this error but I cannot find any details about it nor any log whatsoever.


Have you ever gotten something like this? Do you know how I can debug in a deeper way such an error?

Many thanks in advance.


1 Like

HI Gaetano,

Could you please share the export at We will try to replicate this on our end to check what is causing this. Also, could you please create a new export from the windows instance and try to import it again into linux one?

Ha, I know this one - I bet there’s a restriction on your container for file type, file size, etc. Do ANY files import? Try exporting something small and importing it in the new one. We moved an instance to Kubernetes and couldn’t get big files to import. Finally realized that anything >1 MB wouldn’t import, and Dundas Support said it was likely a K8 setting. Sure was! Increased that limit and we don’t get that error anymore. But it took us many months to find it.

1 Like

For posterity, so people can search it, this error says:

"Import Notification

The file upload failed. Try again and if the problem persists contact your system administrator."


Dear Ken, thanks a lot for your reply.

The file I am trying to import is definitely bigger than 1 MB, it is a Dundas full export of an old test instance which we are using for testing our new docker instance.

So, in the end, did you set some environment variable somewhere in your Dundas container (Deployment)? If so, do you remember which one? Since we are switching to kubernetes soon, would you mind sharing your fix also there?

Thanks again.

Dear Siddhant,
thanks a lot for your reply.

I cannot share those data since they are protected by a CDA we signed with our customer. I should talk to them first.

I have already tried with three different setups to check if some of the export options were somehow linked to the failure but it does not seem the case.

We increased the import size to 20MB in K8 and it worked immediately: 20m

Did you try testing an import <1 MB?

1 Like

Dear Ken, dear Siddhant,

I finally fixed the issue adding the following settings to my nginx reverse proxy used to expose my Dundas instance running on docker:

# avoid 504 Gateway Timeout error
proxy_read_timeout 5m;
proxy_connect_timeout 5m;
proxy_send_timeout 5m;

# avoid Dundas import error for .dbie files >1Mb
client_max_body_size 50M;

The file I needed to import was ~23Mb.

Of course, the same settings should be added to the Dundas website ingress (annotations) if the instance is running in a k8s environment.

Again, thank you for your help.


1 Like