Data Cube parameter changes from "Equals" to "Contains" once you submit the parameter

I’m at the first steps in creating a Data Cube that uses our Salesforce Case table and that’s the only thing I’ve dropped on the canvas with no other changes/filters/etc. New to Dundas so might be missing something basic

When I Configure the SQL SELECT Case and use the Define Parameters to change the record type to Equal a specific case queue ID, and then I Submit, the parameter automatically changes the equal to Contains for that case queue ID, and does that every time I change it back to Equals. Is this supposed to happen and/or am I overlooking something?

I work with SQL and know that I can do a Manual Select SQL query to make this happen, but trying to familiarize myself with the Dundas interface/steps.

1 Like

Hello @jonathan.h

Can you insert here a screenshot?

1 Like

I assume you’re referring to this setting, correct?

1 Like

Christian - That’s correct. In my case, if I were to change the operator to Equals for the 10- value shown in your screenshot and submit it, it automatically changes to “Contains”. I verified with a coworker that it happens for them too, in an unrelated data cube.

I set it to Equals:

But it always reverts to Contains automatically once submitted:

What data type is the RecordTypeId field in question? When I select the token menu under Value, all I get are tokens and none of equals/contains/etc.

To get the Contains/Equals/etc. operators, right-click within the Value field where you have “10-” in your screenshot, that populates the operator menu.

The RecordTypeID data type in this case is nchar – although when I had a coworker try this on a separate, unrelated, data cube with different different data type fields they also experienced this same issue.

@jeff Can you weigh in on this, is this an expected result for this?

Hi @jonathan.h,

This seems like a bug in the UI to me, let me talk to our dev team for you. I believe I am able to reproduce this. In the meantime, maybe switch to a manual SQL query and perform the contains filter manually?


1 Like

Perfect, appreciate the response. Yeah, I went with Manual Select to retain the Equals, but just wanted to make sure that I wasn’t doing something wrong.

Hi @jonathan.h,

I logged this for our team to investigate and potentially fix if there is an issue. #ref80133

Please let me know if you have any issues with the manual method. Also - full disclosure, i didn’t realize that you could right click on that menu as I’ve always used the manual method!!! Learn something new every day, Dundas BI is just that big.

1 Like

So i feel a bit better not knowing about this feature… Apparently this option was not intended to be exposed in the data cube designer and does not have any effect.

There is a coming fix to remove these options entirely; they never should have been there in the first place and don’t apply to string parameter values at all.

thanks for finding this @jonathan.h

1 Like