Can't display chart when cube is checked out (v6)

I have a warehoused cube with many charts coming off from it.

If I checkout the cube, all the charts fail with a message that the cube has not been built since the last check in. This has only been happening in version 6, never in version 5.

Has anything changed, and what reason could there be for this change.

It is really annoying and disruptive. I often check out cubes just to have a look at them and if it breaks all the dashboards this is not feasible.

Has anyone else noticed this? Is it only for my user but other users will see the data?


Hi David,

This does not seem normal. The expected behavior in this scenario would be retrieving the data from the original source when a warehoused cube is checked out to you.

Also, for your information, check-in/ check-out status is individual to the user. If a user checks out the cube, only for that user the cube is checked out and data is retrieved from the original data source, however, the other users will still see a result that is retrieved from the warehouse database. Warehouse data is retrieved if the storage type is “Warehoused” AND the cube is in check-in status for that user.

So, it should not throw that error message when you have checked out your cubes. I tried to reproduce this issue, but everything was working fine and once the cube was checked out, I could still see the result in dashboards.

To better troubleshoot this issue, I’d suggest communicating through emails and I’d appreciate if you could clarify the following in your email:

  1. The exact version of your Dundas BI,
  2. Complete error message with stack trace,
  3. Other errors if there is anything related in Admin -> Logs
  4. If this issue happens globally for any cube or any user or just for some specific cases

Thank you

Thanks Azar - I’ll send a separate email to support.

I have had this issue before too I knew it was not just me, to be fair we saw it while trying to fix a different issue.

Hi Azar,

I had reported this exact same issue way back in December 2018 and received the following reply from Christian Pervan.

The error you are experiencing is part of a known bug (Issue 76930). We have added you to the bug report. You will be informed when a fix is released.

Christian Pervan | Business System Analyst, Support Associate

I even tried to follow up but never received any update.

Hi David,

I was able to replicate this issue and forwarded it to R&D team and was informed that it was just fixed. The defect # is 80225. Hopefully, the fix can be included in the upcoming minor.

Great - thanks Azar

Hi David,

I’m glad to let you know that we have just released V6.0.2 on support site. This version includes the fix for defect #80225, which should fix the issue we discussed here.

You may find the release note here.

Hi @david.glickman, have you been able to upgarde to V6.0.2 and check if this issue is resolved now?

I did and yes it fixed it, now it is the slow query the DB instead of the error message. but thats a good thing.

Thanks @james.davis. I don’t understand the slow query part. Do you mean the Dashboards/Reports load slowly if the Data Cube is checked out?

oh it when the cube is warehoused and checked out (most of mine are warehoused).